9.28.2022 Network Interruption
Incident Report for Raken, Inc
Resolved
Latest Update from Amazon Web Services:

"Starting at 1:31 PM PDT, error rates and latencies for invokes on API Gateway endpoints in the US-WEST-2 Region are now close to pre-event levels, and we continue to work on the remaining hosts that are affected by the contention issue. Several AWS services, including AWS Connect and Lambda are seeing signs of strong recovery. We expect all services to recover as API Gateway error rates and latencies return to normal levels. Customers should be seeing recovery at these error levels as well. We will continue to provide updates until the error rates and latencies have returned to normal levels."

We should be getting back to expected behavior and load times for all Raken features.

We thank you for your patience during this time and apologize for any inconvenience this may have caused.
Posted Sep 28, 2022 - 21:03 UTC
Update
An update from the AWS status page says they are still experiencing some issues, but are continuing to resolve the elevated error rates:

"We continue to see a significant improvement in error rates, starting at 10:40 AM PDT, but are not seeing full recovery yet. The issue is caused by contention within the subsystem that is responsible for request processing within the API Gateway service."

Some testing in Raken to see if things are getting back to normal has shown that some of the impacted features are now intermittently working.

We'll continue to post updates as this resolution gets closer. Thank you.
Posted Sep 28, 2022 - 19:23 UTC
Identified
The issue has been identified and appears to be related to AWS Api Gateway having issues. It is primarily impacting tracking, safety, weather, integrations & reporting.

Luckily, AWS usually has these issues resolved quickly. We will update you when we have more information.
Posted Sep 28, 2022 - 17:44 UTC
Investigating
We are currently investigating reported issues involving intermittent network errors. We will provide additional updates as they become available and greatly appreciate your patience throughout this process. Please contact our Support team with any questions: help@rakenapp.com
Posted Sep 28, 2022 - 17:03 UTC
This incident affected: Web App, Mobile Apps - iOS, Mobile Apps - Android, Daily Reports, and Time Cards.